What's new
Xen Factory

Register today to become a member! Once signed in, you'll be able to start purchasing our products, ask questions, request support and suggest new ideas!

  • Clement is on vacation leave until the 22nd of August.
    Support or questions about his add-on will be answered on a very very slow basis till his return. Sorry for the inconvenience.
  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Fixed Missing column 'xfa_tt_template'

Brettflan

New Member
As per this on the main XF community forums:

This was a new install of version 3.0.1 of this addon to XF 2.2.3 patch 1.
Posting a copy of the above info below.



We're getting this error in XF 2.2.3 patch 1 (not updated to 2.2.4 yet) with this addon version 3.0.1, when a new node is attempted to be created. It happens on our test forum and our live forum.

XF\Db\Exception: MySQL statement prepare error [1054]: Unknown column 'xfa_tt_template' in 'field list' - src/XF/Db/AbstractStatement.php:228

Stack trace:
Code:
INSERT INTO `xf_node` (`node_type_id`, `title`, `node_name`, `description`, `parent_node_id`, `display_order`, `display_in_list`, `style_id`, `navigation_id`, `node_id`, `effective_style_id`, `breadcrumb_data`, `effective_navigation_id`, `xfa_tt_template`) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)
------------

#0 src/XF/Db/Mysqli/Statement.php(196): XF\Db\AbstractStatement->getException('MySQL statement...', 1054, '42S22')
#1 src/XF/Db/Mysqli/Statement.php(39): XF\Db\Mysqli\Statement->getException('MySQL statement...', 1054, '42S22')
#2 src/XF/Db/Mysqli/Statement.php(54): XF\Db\Mysqli\Statement->prepare()
#3 src/XF/Db/AbstractAdapter.php(94): XF\Db\Mysqli\Statement->execute()
#4 src/XF/Db/AbstractAdapter.php(218): XF\Db\AbstractAdapter->query('INSERT  INTO `x...', Array)
#5 src/XF/Mvc/Entity/Entity.php(1510): XF\Db\AbstractAdapter->insert('xf_node', Array, false)
#6 src/XF/Mvc/Entity/Entity.php(1242): XF\Mvc\Entity\Entity->_saveToSource()
#7 src/XF/Mvc/FormAction.php(69): XF\Mvc\Entity\Entity->save(true, false)
#8 src/XF/Mvc/FormAction.php(187): XF\Mvc\FormAction->XF\Mvc\{closure}(Object(XF\Mvc\FormAction))
#9 src/XF/Admin/Controller/AbstractNode.php(110): XF\Mvc\FormAction->run()
#10 src/XF/Mvc/Dispatcher.php(350): XF\Admin\Controller\AbstractNode->actionSave(Object(XF\Mvc\ParameterBag))
#11 src/XF/Mvc/Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass('XF:Forum', 'Save', Object(XF\Mvc\RouteMatch), Object(SV\MultiPrefix\XF\Admin\Controller\Forum), NULL)
#12 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(SV\MultiPrefix\XF\Admin\Controller\Forum), NULL)
#13 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#14 src/XF/App.php(2326): XF\Mvc\Dispatcher->run()
#15 src/XF.php(488): XF\App->run()
#16 admin.php(13): XF::runApp('XF\\Admin\\App')
#17 {main}

Request state:
Code:
array(4) {
  ["url"] => string(24) "/admin.php?forums/0/save"
  ["referrer"] => string(92) "https://forums.taleworlds.com/admin.php?forums/add&parent_node_id=0&forum_type_id=discussion"
  ["_GET"] => array(1) {
    ["forums/0/save"] => string(0) ""
  }
  ["_POST"] => array(18) {
    ["node"] => array(7) {
      ["title"] => string(13) "TEST - DELETE"
      ["description"] => string(21) "testing node creation"
      ["node_name"] => string(0) ""
      ["parent_node_id"] => string(3) "546"
      ["display_order"] => string(1) "1"
      ["display_in_list"] => string(1) "1"
      ["navigation_id"] => string(0) ""
    }
    ["forum_type_id"] => string(10) "discussion"
    ["sv_multiprefix_min_prefixes"] => string(1) "0"
    ["sv_multiprefix_max_prefixes"] => string(1) "0"
    ["allow_posting"] => string(1) "1"
    ["count_messages"] => string(1) "1"
    ["find_new"] => string(1) "1"
    ["similar_threads_include"] => string(1) "1"
    ["allow_index"] => string(5) "allow"
    ["min_tags"] => string(1) "0"
    ["allowed_watch_notifications"] => string(3) "all"
    ["default_sort_order"] => string(14) "last_post_date"
    ["default_sort_direction"] => string(4) "desc"
    ["list_date_limit_days"] => string(1) "0"
    ["_xfToken"] => string(8) "********"
    ["_xfRequestUri"] => string(63) "/admin.php?forums/add&parent_node_id=0&forum_type_id=discussion"
    ["_xfWithData"] => string(1) "1"
    ["_xfResponseType"] => string(4) "json"
  }
}

It seems a database table should have been modified to have the 'xfa_tt_template' column added to it when the addon was installed, but it wasn't for some reason? I tried to Rebuild the addon, but that made no difference.


I suppose I could probably just add that column to the xf_node table (as string type) through phpMyAdmin, but this is obviously something the addon should have handled, and for all I know there will be further issues even if I did that.
Since I'd rather not go for a manual fix to an integral part of this addon, I've had to just disable this addon for now so that we can actually create new nodes.

@MtoR
 

Clement

Freaky Coder
Staff member
No no this is a column that is not there anymore for a reason.
I'm going to provide a release to fix that as stated on xf.com.
 
Top