• We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Cannot Reproduce Missing files

Robert9

Member
Joined
Sep 28, 2016
Messages
562
I have updated our core version from 1.6 to 1.7

and get

Exception: Could not find class XFA\Core\XF\Entity\Attachment when attempting to extend XF\Entity\Attachment src/XF/Extension.php:174


#0 src/XF/Mvc/Entity/Manager.php(53): XF\Extension->extendClass('XF\\Entity\\Attac...')
#1 src/XF/Mvc/Entity/Manager.php(67): XF\Mvc\Entity\Manager->getEntityClassName('XF:Attachment')
#2 src/XF/Mvc/Entity/Manager.php(223): XF\Mvc\Entity\Manager->getEntityStructure('XF:Attachment')
#3 src/XF/Mvc/Entity/Repository.php(35): XF\Mvc\Entity\Manager->getFinder('XF:Attachment')
#4 src/XF/Repository/Attachment.php(208): XF\Mvc\Entity\Repository->finder('XF:Attachment')
#5 src/XF/Pub/Controller/Thread.php(53): XF\Repository\Attachment->addAttachmentsToContent(Object(XF\Mvc\Entity\ArrayCollection), 'post')
#6 src/addons/ThemeHouse/QAForums/XF/Pub/Controller/Thread.php(50): XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#7 src/addons/XFA/ThreadTabs/XF/Pub/Controller/Thread.php(20): ThemeHouse\QAForums\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#8 src/addons/Truonglv/Schedule/XF/Pub/Controller/Thread.php(18): XFA\ThreadTabs\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#9 src/addons/XenAddons/Showcase/XF/Pub/Controller/Thread.php(11): Truonglv\Schedule\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#10 src/addons/SV/ModeratorEssentials/XF/Pub/Controller/Thread.php(28): XenAddons\Showcase\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#11 src/addons/SV/AlertImprovements/XF/Pub/Controller/Thread.php(24): SV\ModeratorEssentials\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#12 src/XF/Mvc/Dispatcher.php(350): SV\AlertImprovements\XF\Pub\Controller\Thread->actionIndex(Object(XF\Mvc\ParameterBag))
#13 src/XF/Mvc/Dispatcher.php(261): XF\Mvc\Dispatcher->dispatchClass('XF:Thread', 'Index', Object(XF\Mvc\RouteMatch), Object(SV\AdvancedBbCodesPack\XF\Pub\Controller\Thread), NULL)
#14 src/XF/Mvc/Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(SV\AdvancedBbCodesPack\XF\Pub\Controller\Thread), NULL)
#15 src/XF/Mvc/Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#16 src/XF/App.php(2184): XF\Mvc\Dispatcher->run()
#17 src/XF.php(391): XF\App->run()
#18 index.php(20): XF::runApp('XF\\Pub\\App')
#19 {main}
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,958
Seems I made an incorrect update of the add-on.
Will have to fix.

Get the 1.6 version files, then overwrite with 1.7 files, you should get the missing ones.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
4,958
I checked, files are here.
You sure you uploaded them correctly ?