• This area is dedicated to the support of our xF1 add-ons. For xF2, please use the dedicated area: HERE.
  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Support Need help with RM MarketPlace

mono

New Member
Joined
Nov 13, 2017
Messages
11
Not too sure what's going on this is what it's saying when I click on it in admin.

Code:
An exception occurred: Invalid model 'XenResource_Model_Resource' specified in /home/mono/public_html/library/XenForo/Model.php on line 192

XenForo_Model::create() in XFA/RMMarketPlace/Option/ResourceCurrencySelector.php at line 17
XFA_RMMarketPlace_Option_ResourceCurrencySelector::renderOption() in XenForo/ViewAdmin/Helper/Option.php at line 345
XenForo_ViewAdmin_Helper_Option::_renderCallbackOptionHtml() in XenForo/ViewAdmin/Helper/Option.php at line 72
XenForo_ViewAdmin_Helper_Option::renderPreparedOptionHtml() in XenForo/ViewAdmin/Helper/Option.php at line 33
XenForo_ViewAdmin_Helper_Option::renderPreparedOptionsHtml() in XenForo/ViewAdmin/Option/ListOptions.php at line 29
XenForo_ViewAdmin_Option_ListOptions->renderHtml() in XenForo/ViewRenderer/Abstract.php at line 229
XenForo_ViewRenderer_Abstract->renderViewObject() in XenForo/ViewRenderer/HtmlAdmin.php at line 78
XenForo_ViewRenderer_HtmlAdmin->renderView() in XenForo/FrontController.php at line 606
XenForo_FrontController->renderView() in XenForo/FrontController.php at line 158
XenForo_FrontController->run() in /home/mono/public_html/admin.php at line 13
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,753
Hi,

As stated on the product page, you need to have XenResource Manager for this add-on to work.
You don't seem to.

Clément
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,753
You have XenForo, XenResource Manager is one of their official add-on.
 

mono

New Member
Joined
Nov 13, 2017
Messages
11
Found what I needed but it's say this
Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Table 'MC-C.xf_resource' doesn't exist - library/Zend/Db/Statement/Mysqli.php:77
I've tried to uninstall and reinstall the add-on but I get the same thing.
 
Last edited:

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,753
From the error it means the resource manager add-on is still not installed.

Did you install it as I stated ?

Clément
 

mono

New Member
Joined
Nov 13, 2017
Messages
11
I'm now getting this

Server Error

Mysqli prepare error: Unknown column 'xfa_rmmp_purchases' in 'where clause'

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  5. XenForo_Model->fetchAllKeyed() in XenResource/Model/Resource.php at line 112
  6. XenResource_Model_Resource->getResources() in XFA/RMMarketPlace/Extends/XenResource/ControllerPublic/Resource.php at line 274
  7. XFA_RMMarketPlace_Extends_XenResource_ControllerPublic_Resource->actionIndex() in XenForo/FrontController.php at line 351
  8. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  9. XenForo_FrontController->run() in /home/mono/public_html/index.php at line 13
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,753
You have reinstalled the marketplace after correct installation of Resource Manager ?
 

mono

New Member
Joined
Nov 13, 2017
Messages
11
I've checked everything and even re-installed the site but it's still coming up with this

Server Error
Mysqli prepare error: Unknown column 'xfa_rmmp_purchases' in 'where clause'

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  5. XenForo_Model->fetchAllKeyed() in XenResource/Model/Resource.php at line 112
  6. XenResource_Model_Resource->getResources() in XFA/RMMarketPlace/Extends/XenResource/ControllerPublic/Resource.php at line 274
  7. XFA_RMMarketPlace_Extends_XenResource_ControllerPublic_Resource->actionIndex() in XenForo/FrontController.php at line 347
  8. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  9. XenForo_FrontController->run() in /home/mono/public_html/index.php at line 13
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,753
Uninstall the marketplace product then go to the xf_resource and xf_user tables and delete all columns that starts with xfa_rmmp then reinstall.

It should fix it.
 

mono

New Member
Joined
Nov 13, 2017
Messages
11
I don't see any tables with xfa_rmmp after I uninstall I only see them when it's installed but not in xf_resource and xf_user
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,753
Not a table a column. So you see none of them when it's not installed ?

Could you please install and make an extract of the table structure of the xf_resource and xf_user tables ?
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,753
Install it, go to phpmyadmin to the table xf_resource (then xf_user) and do an export without data
 

mono

New Member
Joined
Nov 13, 2017
Messages
11
There dose not seem to be a way I can send them to you on here.