• This area is dedicated to the support of our xF1 add-ons. For xF2, please use the dedicated area: HERE.
  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Fixed Server Errors

Kerby

Member
Joined
Feb 29, 2016
Messages
31
Hello @MtoR
Since I installed your Addon I get lots of these server errors:
I censored my domain for security reasons
Code:
Server Error Log
Error Info
ErrorException: Undefined index: hasRosterInGame - library/XFA/Tournament/Model/Tournament.php:522
Generated By: Kerby, Yesterday at 11:51 PM
Stack Trace
#0 /var/www/(CENSORED)/library/XFA/Tournament/Model/Tournament.php(522): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/www/(CENSORED)...', 522, Array)
#1 /var/www/(CENSORED)/library/XFA/Tournament/Extends/XenForo/ControllerPublic/Thread.php(89): XFA_Tournament_Model_Tournament->canRegister(Array, Array)
#2 /var/www/(CENSORED)/library/XenForo/FrontController.php(351): XFA_Tournament_Extends_XenForo_ControllerPublic_Thread->actionIndex()
#3 /var/www/(CENSORED)/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#4 /var/www/(CENSORED)/index.php(13): XenForo_FrontController->run()
#5 {main}
Request State
/var/www/(CENSORED)/library/Zend/Debug.php:82:
array (size=3)
  'url' => string 'https://(CENSORED)/index.php?threads/test.1/' (length=66)
  '_GET' =>
    array (size=1)
      'threads/test_1/' => string '' (length=0)
  '_POST' =>
    array (size=0)
      empty
I would very much appreciate if you could resolve this issue :)
Cheers,
Kerby
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,209
Hi,

Have you activated the roster compatibility in the options ?

Clément
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,209
And you have that add-on ?

Which one have you installed prior to the other ?
 

Kerby

Member
Joined
Feb 29, 2016
Messages
31
I've installed both together with Addon Install & Upgrade from Chris D by batch install processing. So I don't know which exactly was first installed by Addon Install & Upgrade.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,209
Ah. Then if roster has been installed in second, you will need to run the add compatibility to roster in the tournament menu of the admincp.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,209
Was this in a tournament with a thread ?
 

Kerby

Member
Joined
Feb 29, 2016
Messages
31
Yes. I think it happens when you add a roster to a tournament or edit them.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,209
Yes ok, but have you configured tournament so that it creates a thread along with each tournament ?
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,209
Then this is maybe a bug, will have to look into it when doing the next version.
 
  • Like
Reactions: Kerby

Kerby

Member
Joined
Feb 29, 2016
Messages
31
Or is the database corrupt because of the install addon & upgrade from Chris D probably first installed tournaments and then roster? I deinstalled both addons, then installed roster and after that tournament and activated roster compatibility in ACP Tournaments options but error is still logged.

Could you please fix it until End of 2016? Would be nice.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
5,209
I don't know, will have to investigate.

Yes end of 2016 should be feasible.