• We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Support server icons folder is missing

oO5 Dynasty

Member
Joined
Nov 16, 2015
Messages
92
1640996706084.png

I'm inside of my FTP app and I'm looking for the icons folder which seems to be missing.

/user.oo5dynasty.com/public_html/data/xfa

I see this folder
customusernameicons
but I do not see trophiesenhancement/icons subdirectory


When I search thru the folders this is where I find some of the folders.
/user.oo5dynasty.com/public_html/src/addons/XFA/TrophiesEnhancement

But then it is missing icons subdirectory

So I am not able to use icons with the add-on right now.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
6,089
Hi,

You need to create that folder.

Clément
 

oO5 Dynasty

Member
Joined
Nov 16, 2015
Messages
92
These icons are missing from the add-on.
When I go to add server icons, it says no icons on the server ( that is the image I showed you from my ACP)
But in your image, it says the icons shall be located in the xfa/trophiesenchancement/icons subdirectory
which should be located in the data folder unless the folder was renamed. ( I did not rename any folders in the xenforo directory)
This is why I said shouldn't that be a part of the add-on. ( meaning, shouldn't I just be able to select the icons and not have to create folders in the FTP.)
1641074949663.png
1641074870092.png

Untitled-5.png

The icons for Custom User Name Icons are there, but the icons for the Trophies add-on are not.

customusernameicons
/user.oo5dynasty.com/public_html/data/xfa/customusernameicons
/user.oo5dynasty.com/public_html/data/xfa/customusernameicons/icons

I can select the icons in the custom user icons add-on just fine, but I can not in the trophies add-on
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
6,089
No no, icons are things you upload yourself, I am not providing any icons.
If you want icons, you need to add them to the stated location.
 

oO5 Dynasty

Member
Joined
Nov 16, 2015
Messages
92
No no, icons are things you upload yourself, I am not providing any icons.
If you want icons, you need to add them to the stated location.
I just read your add-on up and down several times, and there is no place on there that says the customer will have to set up a subdirectory in their FTP to add icons for the add-on (what if somebody has no experience with websites, and purchased your add-on specifically for what is displayed)

It is advertised as if there are icons for the customer, which should be located in the directory xfa under your add-on. ( xfa)
1641076781747.png




xfa/trophiesenchancement/icons subdirectory
That is displayed inside the image and the only reason why I knew to search for that directory on my FTP.
But when I searched, the directory is not there, and I know why now.

So from my point of view as a customer, I see this as false advertising, because It is clearly showing the customer, Icons, and it is showing where the icons should be inside your xfa folder.
Does not say Icons are not included, and also does not say, you need to create your own server icons folder.

Side Note: Shouldn't it be some based server icons that are used at least. You are telling the customer they have to do work in order to have the add-on work completely.
That is kinda like me going to a store buying a TV, and getting home finding out they left out parts, and I need to add those parts for it to work fully.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
6,089
I just read your add-on up and down several times, and there is no place on there that says the customer will have to set up a subdirectory in their FTP to add icons for the add-on (what if somebody has no experience with websites, and purchased your add-on specifically for what is displayed)
I would definitely guide them through the process.

It is advertised as if there are icons for the customer, which should be located in the directory xfa under your add-on. ( xfa)
View attachment 5281




xfa/trophiesenchancement/icons subdirectory
That is displayed inside the image and the only reason why I knew to search for that directory on my FTP.
But when I searched, the directory is not there, and I know why now.

So from my point of view as a customer, I see this as false advertising, because It is clearly showing the customer, Icons, and it is showing where the icons should be inside your xfa folder.
Does not say Icons are not included, and also does not say, you need to create your own server icons folder.
It's not a false advertising, I am just showing an example from the initial customer website.
Trophies can be anything as you are free to define them based on your dedicated criteria so it wouldn't really make sense to have icons embedded.

Side Note: Shouldn't it be some based server icons that are used at least. You are telling the customer they have to do work in order to have the add-on work completely.
Data folder can be renamed by the user, so add-ons can't act on the data directory, that's why the directory is not embedded.
It could maybe have been created though.

That is kinda like me going to a store buying a TV, and getting home finding out they left out parts, and I need to add those parts for it to work fully.
Sometimes you need to put batteries in the remote control ;)
 

oO5 Dynasty

Member
Joined
Nov 16, 2015
Messages
92
I would definitely guide them through the process.

But shouldn't the add-on have the directory that is displayed in your images, automatically installed?
xfa/trophiesenchancement/icons subdirectory with some base images. You literally left the customer with no icons for that part of the add-on.





It's not a false advertising, I am just showing an example from the initial customer website.
Trophies can be anything as you are free to define them based on your dedicated criteria so it wouldn't really make sense to have icons embedded.

You are just saying this right now, but your add-on does not say images are just an example, and the icons are not provided.
Which means it is a false advertisement.
You have to specifically say
XYZ will not be provided. You will have to get XYZ on your own.



Data folder can be renamed by the user, so add-ons can't act on the data directory, that's why the directory is not embedded.
It could maybe have been created though.


In my case my data directory has not been renamed.
/user.oo5dynasty.com/public_html/data/xfa/customusernameicons
/user.oo5dynasty.com/public_html/data/xfa/customusernameicons/icons


Sometimes you need to put batteries in the remote control ;)

That is true, but the company will provide the batteries in the package. ;)
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
6,089
Well you are using customusernameicons and you had to do the same but did not complain.

Well batteries are not always included or didn't use to be.
Anyways I am not gonna argue over and over.

Maybe the folder could be created at install I guess, this is perhaps something I should try to change in the future.
 

oO5 Dynasty

Member
Joined
Nov 16, 2015
Messages
92
Well you are using customusernameicons and you had to do the same but did not complain.


This add-on installed all the directories by itself, I didn't add any icons or create any subdirectories inside Xenforo.



Well batteries are not always included or didn't use to be.

I agree with you here as well, but companies will specifically put on the packaging Batteries are not included. So the customer clearly knows what they are getting inside of the box.

Anyways I am not gonna argue over and over.

To be honest, I never saw this as an argument, we are conversing.

Maybe the folder could be created at install I guess, this is perhaps something I should try to change in the future.

I think that would be really beneficial for the customer/user
Also, less work on your part once it's a part of the core add-on.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
6,089
You must have been creating the folder, or maybe I do in the code, I'll have to check.
I'll have to check.
 

oO5 Dynasty

Member
Joined
Nov 16, 2015
Messages
92
You must have been creating the folder, or maybe I do in the code, I'll have to check.
I'll have to check.
If the icons were missing from that add-on, I would have mentioned it as well.
I just installed it, and it just worked.
I do not mess with add-ons or any of xenforos installation files.
I just install and use the product as it is.
I wouldn't even know how to mess around with add-ons, but it is something I am looking to change in the future.
This has nothing to do with you, but I just want to learn how to code for xenforo, etc, so I can update my website as a, please.

I am just not a fan of having somebody else do something for me, but because I lack the skill currently to develop add-ons for xenforo, I am forced to pay for what I think my website needs.
So yeah I def did not do anything to your add-on.
 

MtoR

Freaky Coder
Staff member
Joined
Nov 14, 2015
Messages
6,089
Oh yeah right custom username icons comes with fam fam icons.
I could include them not a bad idea some are pretty appropriate for trophies.
 
  • Like
Reactions: oO5 Dynasty