What's new
Xen Factory

Register today to become a member! Once signed in, you'll be able to start purchasing our products, ask questions, request support and suggest new ideas!

  • Clement is on vacation leave until the 22nd of August.
    Support or questions about his add-on will be answered on a very very slow basis till his return. Sorry for the inconvenience.
  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Cannot Reproduce User group promotion disappeared

beerForo

Member
I am using the user group promotion that you included.
User has won at least X MOTM awards: 1
It worked before! But now, my January winner IS in the group, but my February winner is NOT (but was before). I ran the user group promotion cron, but no.
 

Clement

Freaky Coder
Staff member
Can you please check into the database and tell me if this user has the field xfa_motm_award set to 1 in the xf_user table.
 

beerForo

Member
Somehow it disappeared.

February's winner:

xfa_motm_award
(empty)

xfa_motm_award_date
1582751426

January's winner:

xfa_motm_award
(empty)

xfa_motm_award_date
1580619541
 

beerForo

Member
30 days because I don't want the avatar to have the banner over that.
But it has not been 30 days since Feb 29th.
 

beerForo

Member
I want them to always have the group promotion. Just not the red banner on the avatar that long. The setting says it is for the avatar only.
 

beerForo

Member
Okay thanks.
I put the (1) manually in the database and ran the cron User Group Promotions. Do you know why the promotion still did not work?
 

Clement

Freaky Coder
Staff member
Maybe it's due to the cron.
Running manually may not trigger promotion, I think they have code to avoid that.
 

beerForo

Member
Okay well then I will add them to the group manually and wait for the bug fix. Thanks for addressing and hope you are well.
 

beerForo

Member
Running manually may not trigger promotion, I think they have code to avoid that.
Well even if the cron runs automatically it is not moving them the the group. Not sure why. It worked when they won it. For now I am manually adding to group but please note this is not working either.
 

Clement

Freaky Coder
Staff member
I checked the code and it's all fine.
I think it's due to the promotion system, editing things manually does not work well.
 

beerForo

Member
As February has 28 days, guess it's the reason. Already remvoed.

This seems to make sense, as, my February contest ended on Feb 26, and 30 days later, the group was removed.

Yeah I know, I must have bad implemented when adding the timeout.

Do you know when this could be fixed? Now, every 30 days this is going to happen to my winners and their user group. Only the avatar banner should be removed. And it is important to keep them in their new group. Thanks
 

beerForo

Member
Hello
This month it did not work at all!
My April contest just ended.
In my database I have:

xfa_motm_award int(10) unsigned
1
xfa_motm_award_date int(10) unsigned
1588194176

In Users >> User group promotions I have:
MOTM
User has won at least X MOTM awards: [1]

The MOTH task ran and the User Group Promotions task ran.

The user is not in the group

I ran the promotion task manually. Still no.

Can this please be fixed? The whole point of the contest is to award them. The award is the new group and it is broken.
 
Top