What's new
Xen Factory

Register today to become a member! Once signed in, you'll be able to start purchasing our products, ask questions, request support and suggest new ideas!

  • Clement is on vacation leave until the 22nd of August.
    Support or questions about his add-on will be answered on a very very slow basis till his return. Sorry for the inconvenience.
  • We are aware that a no permission error was shown when you tried to purchase in the last 2 days, this is now fixed.

Bug Cannot Reproduce User group promotion disappeared

Clement

Freaky Coder
Staff member
It's possible the promotion is only ran when users login, not sure about how it's designed in xF.

Well then which original bug are you talking about ?
Because if it's ran when users login it means it's designed like that in xF so there is no bug ?
 

beerForo

Member
It's possible the promotion is only ran when users login, not sure about how it's designed in xF.
Yes, I can conform this is working as interned. The person logged in and it worked.
Well then which original bug are you talking about ?
Because if it's ran when users login it means it's designed like that in xF so there is no bug ?
No, I mean this is not a bug. But the original post in this thread still is. When do you plan a release with various bug fixes? The last release of this was last year. Thanks and be well!
 

beerForo

Member
Yeah I know, I must have bad implemented when adding the timeout.

When will this bug be fixed?

EVERY month after 30 days the person is REMOVED from the group promotion they won. Because the avatar banner is set for 30 days, BUT is ALSO removes the GROUP because it removes the number of wins from the database. PLEASE fix!
 

beerForo

Member
Okay my friend thanks for your attention. I hope there can be a release soon this product has a few annoying bugs.
 

beerForo

Member
Hello!
This was fixed but one user still did not get promoted.

In the database I had xfa_motm_award blank, so I put in the 1 for all my winners.

Then, I rebuilt the cache "Rebuild user group promotions."

It fixed it for all my winners except one. My April winner was not promoted. I checked everything and he should be promoted.
 

Clement

Freaky Coder
Staff member
I'll have to check the code but that would be honestly hard to find out if code seems fine.
 

beerForo

Member
Okay check and let me know. I checked everything on my side and double checked it all. He won April and I did not have a winner in May because I did a special 3-month contest for May/June/July and set the entry date for 3 months instead of 1. It worked and awarded/promoted the person in July. But I don't see how that would affect this problem. But just letting you know if somehow that is involved. Thanks!
 

Clement

Freaky Coder
Staff member
Honestly everything seems fine to me.

I don't see anything in the code that would lead to that behavior and you said it worked as of July.

Marking this as can't reproduce.
 
Top